
What's New in This Release? 

The following is a list of the New Features and Enhancements that are available in Freeform v12. For 
important technical information about this release, including bugs fixed since the last release, see the 
ReadMe located in the product install directory.  

The ‡ symbol indicates features that are only available in Freeform Modeling Plus. 

AUTOSURFACER ‡ 

Enhancements: 

Updated Options 

The AutoSurfacer has been updated with new options most notably, the Feature Following option. 
When Feature Following is selected, the AutoSurfacer will calculate and apply surfaces to the model 
using 90% fewer patches while simultaneously healing the mesh. When using this option, the following 
options are available in the AutoSurfacer window: Ignore Small Features, Split Feature Lines, An-Iso 
Threshold, Flat Threshold and Tess Level. 

CONSTRUCT CLAY 

New Features:  

Curve Spheres to Clay 

The Curve Spheres to Clay tool has been added to the Construct Clay palette. Using this tool you can edit 
curve spheres and/or convert curve spheres into clay. To create curve spheres either turn on the 
spheres button on the Draw Curve dynabar when drawing a curve, or select a curve and set the dynabar 
option "Spheres" to "On" using this tool.  

Enhancements: 

Mirror Clay 

Two options have been added to the Mirror Clay dynabar - Mirror Whole Piece and Copy Original, and 
the option Create as New Piece has been removed. The two new options control the three mirror 
modes. If Mirror Whole Piece is off the clay on the back of the mirror plane is removed and the clay in 
front of the plane is mirrored into the original piece. 

 

 If Mirror Whole Piece is on and Copy Original is off, the entire piece is mirrored about the mirror plane 
in place (no new piece). Note that the clay in front of the plane goes to the back and the clay in back 
goes to the front. 

If Mirror Whole Piece is on and Copy Original is on, it works like above but a copy is mirrored leaving the 
original in place.  

Wire Cut Clay 



The Wire Cut Clay tool has been enhanced to include a Flip check box on the dynabar that provides the 
ability to control the direction of the plane offset.  

CURVES 

Enhancements: 

Copy from Edge 

The Copy from Edge tool has been enhanced with a new option, All Edges. Using this new option 
provides the capability to copy all edges on a patch/solid surface to create curves. 

Draw Curve 

The Draw Curve dynabar has been enhanced with new modes and a new option. To draw curves you 
must select one of the Draw Curve modes:  

 Create Edit Point Curve 
 Create Traced Curve  
 Replace Curve Segment   

Another new option on the dynabar is Curve Spheres. When selected, curve spheres will be created 
around the curve. Once drawn, you can use the new tools Curve Spheres to Clay, or Curve Spheres to 
Solid. Also, because these spheres are created from curves, you can use the Mirror Curve tool to create 
multiple curve spheres. 

DETAIL CLAY 

Enhancements: 

Variable Round Edge 

The Variable Round Edge tool has been enhanced with the capability to delete individual edge curves. In 
Refine Mode, with an edge curve selected, press the Delete key. This will delete only the selected edge 
curve. The Clear option can still be used to delete all edge curves from the model. 

Shape Clay 

The Shape Clay tool has been enhanced - the Advanced option Minimize Control Points 

- which places edit points only at the intersection of a section curve and another section curve has been 
renamed Minimize Edit Points.    

DEFORM CLAY 

New Features: 

Bend and Twist Clay 

The Bend and Twist Clay tool to select an area and use the Bend Widget to bend or twist clay. Clay 
located outside the widget will be rotated while clay within the widget can be bent and twisted. The 
Bend and Twist tool will preserve detailed clay, including clay with textures or ripples. While you bend 



and twist the clay, the preview of your model will be updated dynamically. However, if the area being 
bent or twisted is too large, the preview will not update until you release the stylus button.  

Enhancements: 

Lattice Deform Box 

The Lattice Deform Box was enhanced with new dynabar options. The new options, Center, Show All, 
Hide Falloff and Proportional provide the capability to set the center of the lattice box, show all lattice 
slices and points, hide the outer two slices of the lattice and move all lattice points proportionally. 

MESH 

New Features: 

Smoothing a Mesh 

The Smooth tool has been added to the Mesh Tools palette. Use this tool to interactively smooth the 
edges of a mesh. 

Enhancements: 

Select Mesh Area 

The dynabar for the Select Mesh Area tool has been enhanced with new dynabar options. You can now 
select a mesh area using a Seed Point. This option selects polygons by flood-filling from a seed point that 
you select. Also new to the dynabar is the ability to Copy Selection and Create New Mesh. This option 
copies the selection area and creates a new mesh using this area. The original mesh will be hidden upon 
creation of the new mesh.  

The remaining Convert and Create dynabar options have been renamed. The renamed options are, Cut 
Selection, Cut Selection and Create New Mesh, Convert Mesh Selection to Clay, and Copy Mesh 
Selection to Clay. 

Other changes to the dynabar include the removal of the Add to Selection icon. In Freeform v12, Select 
Mesh Area is set to Add to Selection by default and the Remove from Selection icon has been changed 
on the dynabar.  

Select Mesh with Curve Loop 

The dynabar for the Select Mesh with Curve Loop tool has been enhanced. New to the dynabar is the 
ability to Copy Selection and Create New Mesh. This option copies the selection area and creates a new 
mesh using this area. The original mesh will be hidden upon creation of the new mesh.  

The remaining Convert and Create dynabar options have been renamed. The renamed options are, Cut 
Selection, Cut Selection and Create New Mesh, Cut Selection and Convert to Clay, and Copy Selection 
and Convert to Clay.  

 



 
 
MOLD 

Enhancements: 

Fix Draft 

The Fix Draft tool has been enhanced to sync the Draft Angle found on the dynabar to Angle for Draft 
Colors found in Tools>Options>View>Setup. Modifying the value in one location will automatically 
update the value in the other location.  

Fix Draft Selection 

The Fix Draft Selection tool has been enhanced with two new dynabar options, Limit to Selection and 
Thin Piece Mode. Use Limit to Selection to select only the surface that the tool is in contact with. Use 
Thin Piece Mode to... 

Fix Draft Selection has also been enhanced to sync the Draft Angle found on the dynabar to Angle for 
Draft Colors found in Tools>Options>View>Setup. Modifying the value in one location will automatically 
update the value in the other location.  

Pull Direction Vector 

In v12, Freeform has renamed the Parting Line View options to be Pull Direction View options. To access 
these options go to the View menu>Pull Direction View. On the sub-menu you will find the find the 
following options renamed:  

 Set Parting Line View has been renamed Set Pull Direction to View 
 Flip Parting Line View has been renamed Flip Pull Direction 
 Show Pull Direction Vector has been renamed Show Vector 

 You now control the display of Pull Direction Colors (formerly Parting Line Colors) from the Pull 
Direction View submenu. The following options can be found on the submenu: 

 The option Show Parting Line Colors has been renamed Show Colors.  
 The option Standard Colors will display the standard pull direction colors.  
 The option Rainbow Colors (formerly Parting Line Rainbow Map) will display a rainbow 
 of color across the area from 0 degrees of draft to the user-defined draft angle 

You also have the ability to Flip Colors. This switches the direction of the draft colors. The Updated 
Parting Line Colors option that is found on the dynabars of certain mold and curve tools has been 
renamed Update Colors.  

OBJECT LIST 

New Features: 

Clay Utilities 

The Object List Context Menu has a new sub-menu, Clay Utilities. The commands found on this sub-
menu include: Copy to Mesh, Fill Voids, Create Offset Piece, Add to Mask and Add to Buck. 



Divide Mesh 

The Object List Context Menu for Mesh pieces has a new option, Divide Mesh. The option divides an 
existing mesh into smaller triangles. Each triangle side will be divided into two parts (four triangles from 
one side). 

Export Planes as .CLY Files 

A new option has been added to the Export menu that provides the capability to export sketch planes 
and sketch entities as a .CLY file. 

Mesh Boolean Operators 

The Boolean operators - Combine, Remove, and Intersect have been added to the Object List Context 
Menu for mesh pieces.  

Mesh Utilities 

The Object List Context Menu has a new sub-menu, Mesh Utilities. The commands found on this sub-
menu include Copy to Clay, Mirror, Divide, Reverse, Merge Coplanar Facets and Reduce. 

Reducing a Mesh 

Use the Subdivide Mesh option, found on the Object List Context Menu for Mesh pieces to divide a 
selected mesh into smaller triangles. Each triangle side will be divided into two parts (four triangles from 
one). 

Enhancements: 

Combine as New 

Use the Object List option Combine as New to combine multiple object types (clay/mesh) into one new 
piece. 

Copy Clay to Mesh 

The Object List Context Menu for Clay pieces has been enhanced with an option to Copy Clay to Mesh. 
You can use this option to convert a clay piece to mesh material. 

Duplicate 

The Duplicate option, found on the Object List Context Menu has been enhanced to provide the 
capability to duplicate a selected Folder and its contents as well as selected Planes in the Object List. 

Hide Associated Objects 

The eye icon indicates if the object is visible. The Object List has been enhanced so that you can also 
hide the associated objects of a piece, for example a curve. Pressing the Alt key and clicking the eye icon 
will hide or show the associated objects. 

Object List Search Function 



The Object List Search Function was enhanced with new search options. The options, Find & Select All 
and Find & Select Cumulatively were replaced with Select One, Add to Selection, and Select All 
Instances. These new options provide the ability to highlight search results one object at a time, to keep 
search results highlighted as you scroll through the Object List and to highlight all search results in the 
Object List. 

Also added to the Search Function is the option, Loop Back to Start/End. Select this option to 
automatically continue searching the Object List when the search has reached the top or bottom of the 
Object List. 

Object List Toolbar 

The Object List was updated with a toolbar. The Toolbar runs across the bottom of the Object List and 
has eight icons. The icons provide the ability to sort the Object List alphabetically, to hide/show folders, 
planes, curves, patches, solids, and hidden objects, as well as open the Object List Search Function. 

Override Folder Visibility (for Pieces) 

The option, Override Folder Visibility (for Pieces) was added to the new Object List Options dialog 
through the Tool menu. You can use this option so that pieces in the Object List will remain visible in the 
Object List when the Flatten Folders option has been enabled on the Object List toolbar. 

Renaming in the Object List 

The Object List has been enhanced to improve the renaming of objects. In previous versions of 
Freeform, you had to rename an object using the Object List Context Menu. While that option still exists, 
with the option Rename objects with double click selected in the Tools>Options>General>Object List 
selected, you can double click an object name in the Object List to rename that Object. You cannot 
double click to rename a folder or sketch elements in the Object List.  

See Through On/Off 

The See Through Objects function has been enhanced to provide the capability to set the see-through 
status of multiple objects at the same time. With multiple objects selected in the Object List you can 
access this option by right-clicking one of the selected objects to view the Object List Context Menu. 

Show Children/Hide Children 

The Show Children/Hide Children options found on the Object List Context Menu for planes are 
enhancements that provide the capability to show or hide all sketch elements from a selected plane in 
the Object List and workspace.  

PATCHES/SOLIDS ‡ 

New Features: 

Curve Spheres to Solid ‡ 

The Curve Spheres to Solid tool has been added to the Patches/Solids palette. Using this tool you can 
edit curve spheres and/or convert curve spheres into clay. To create curve spheres either turn on the 
spheres button on the Draw Curve dynabar when drawing a curve, or select a curve and set the dynabar 
option "Spheres" to "On" using this tool. 



Project Patch to Clay ‡ 

The Project Patch to Clay tool has been added to the Patches/Solids palette. Using this tool you can 
project a solid or patch surface onto a clay piece. 

Solidify ‡ 

The Solidify tool has been added to the Patches/Solids palette. Using this tool you can convert one or 
more patches or solids into one solid. 

Enhancements: 

Create Patch 

The advanced options of the Create Patch tool have been enhanced. Specifically, the Smoothing slider 
has new controls. When the slider is set to zero the advanced features are disabled; there will be no 
smoothing, no oversampling, and no sampling beyond the boundaries and no knot reduction. With the 
slider set to one (1) the result is similar to the smoothing with a zero setting but the advanced options 
will be applied. With the slider to the right the tool will average a sample of voxels -  this may decrease 
accuracy, but ripples will be reduced and a smooth patch will be created. 

Shape Patch 

The Shape Patch tool has been enhanced - the Advanced option Minimize Control Points - which places 
edit points only at the intersection of a section curve and another section curve has been renamed 
Minimize Edit Points. 

Wire Cut Solids ‡ 

The Wire Cut Solids tool has been enhanced to include a Flip check box on the dynabar that provides the 
ability to control the direction of the plane offset. Also added to the dynabar are a Height/Depth box 
and Raise and Lower options. Using these options you can emboss solid material.    

PLANES 

Enhancements: 

Edit Plane 

The Edit Plane dynabar has been enhanced with a new option, Orient through Point Cloud. This option 
will assess the piece in mesh format, identify all mesh vertices, and Conceptualize these vertices as a 
point cloud. Using this data the plane is positioned through the cloud in such a way that the plane will 
be aligned to the plane of greatest cross-sectional area, and approximated to the center of mass. 

SCULPT CLAY 

New Features: 

Hot Wax 



The Hot Wax tool has been added to the Sculpt Clay palette. Use this tool to interactively melt the edges 
of the clay with a ball-shaped tool by adding or removing clay. Hot Wax has unique dynabar options for 
smoothing clay - Melt, Smooth, Add and Remove. 

Enhancements: 

Smooth Tool 

The Smooth tool has an enhanced to provide the capability to smooth using v10 smoothing or v11 
smoothing. New dynabar options have also been added to the Smooth Tool that provide the capability 
to select a Smoothing mode. The available modes are Outside Smooth and Inside Smooth. The Outside 
Smooth option smooths the clay with an area of influence outside the tool sphere while the Inside 
Smooth option uses the area of influence within the tool sphere. 

SELECT/MOVE CLAY 

New Features: 

Posing 

Use the Pose tool to adjust and accommodate the movement of clay, or mesh, patch or solid elements. 
Once you have placed the Pivot point, the pivot shaft will appear in your workspace. Using the stylus, 
grab one of the handles on the pivot shaft to bend the element.  

Enhancements: 

3D Box Select: Select Hidden Objects 

The Select Objects with 3D Box tool was enhanced with a dynabar option that provides the ability to 
select hidden objects in the workspace. 

Mask & Selection Tools 

The Mask tool and Clay Selection tools have been enhanced. The Add to Selection icon has been 
removed from the dynabar. In Freeform v12,  Add to Selection is set by default and the Remove from 
Selection icon has been changed on the dynabar. 

Separate Tool 

The Separate Tool has been enhanced with the capability to separate a mesh piece. 

TOOLS MENU 

New Features: 

Colors Options 

The Tools Menu>Options>View>Colors dialog has a new option, Use Background Image. Selecting the 
checkbox provides the ability to browse for and select a specific image to use for workspace 
background.  

Curve Options 



The Tools Menu>Options>General>Curves dialog has a new option, Preview Draw Curve fit point. This 
option, selected by default, will enable a preview of the curve point when drawing a curve that will be fit 
to a clay, mesh or patch/solid surface. A shadow point will appear on the surface identifying where the 
fit point will be placed when the curve is not in contact with the surface. 

Object List Options 

The Tools Menu>Options>General section has a new page of options specifically for the Object List. In 
previous versions some of these options were located on different dialog pages, such as Force Unique 
Object List Names. New options have also been added to this added, such as Show Toolbar, and 
Override Folder Visibility (for Pieces). 

Enhancements: 

Mass Properties 

The Mass Properties tool was enhanced with the capability to handle mesh pieces. 

Piece Density 

The Piece Density tool was enhanced with the capability to handle mesh pieces. 

Setup Options 

The Tools>Options>View>Setup dialog has renamed the Parting Line Draft Angle input. This input is now 
named, Angle for Draft Colors. 

TWEENING 

Enhancements: 

Reposition Piece 

The Reposition Piece tool has been enhanced when working with tweened pieces. In the advanced 
options, the movement measurement has been renamed Max Movement.   

VIEW MENU 

New Features: 

Hide/Show Mesh Pieces 

A new toggle option has been added to the Utilities palette. Hide/Show Mesh Pieces toggles the display 
of mesh pieces on and off. When selected, only the active mesh piece in the Object List will be shown in 
the workspace. When deselected, all entities will be shown in the workspace. 

Pull Direction Vector 

Parting Line Colors menu has been renamed Pull Direction Vector. The submenu options have been 
reorganized and renamed. 

 


